Raid Recovery

I have a broken Western Digital MyBookLive with two 2TB drives on-board. One appeared to have gone Bad which uncharacteristically took the whole ‘network serving’ concept off line

I took out and marked both 2TB drives as A and B
(do it! or you will wish you had…)
then tested them both on my Linux MINT 20 Ulua (AKA Ubuntu 20) workstation. BE SURE yours has NO raid devices on it EXCEPT what we are doinf here : )

You can ‘hot swap’ drives it seems and I have been doing so over a SATA cable that hangs out the Server box. 
I am not responsible for having said that; It just did not break
MY workstation

None of the following works over USB-
USB does not send all the drive stats needed, it seems..

“A” showed S.M.A.R.T. Error
by using gsmartcontrol which confirmed multiple bad sectors waiting to be relocated- which Was Not Happening : )
“B” seemed Okay- But I homed in on “A”. Just Cos
Note I only left “A” connected, and NOT “B”.

OK so, all as ‘root’
I ran:
lsblk
to identify what block/storage Devices the system could still ‘see’

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 596.2G 0 disk
├─sda1 8:1 0 100M 0 part
└─sda2 8:2 0 596.1G 0 part /mnt/d2win
sdb 8:16 0 119.2G 0 disk
├─sdb1 8:17 0 71.7G 0 part /mnt/win
├─sdb2 8:18 0 547M 0 part
├─sdb3 8:19 0 7.8G 0 part [SWAP]
└─sdb4 8:20 0 39.1G 0 part /
sdc 8:32 0 931.5G 0 disk
└─sdc1 8:33 0 931.5G 0 part /mnt/1TBDATA
sdh 8:112 0 1.8T 0 disk
├─sdh1 8:113 0 1.9G 0 part
├─sdh2 8:114 0 1.9G 0 part
├─sdh3 8:115 0 489M 0 part
└─sdh4 8:116 0 1.8T 0 part

There at 1.2TB was the drive with 4 partitions of /dev/sdh…
the largest, /dev/sdh4 likely holds the mass of Data I am after

mount /dev/sdh4 /mnt/tmp
gives:”  unknown filesystem type ‘linux_raid_member”
Reading up some it looks like we need the “mdadm” (Multi Disk Admin Tools?) command line utilities and the use of this command:
mdadm --assemble --scan
This it seems will find anythign that looks liek RAid partiotns and mount them as such under /dev/md*

so! 
ls /dev/md*
gave me:
/dev/md126 /dev/md127

So!

root@SSD128:/mnt# mount /dev/md126 /mnt/tmp
mount: /mnt/tmp: can’t read superblock on /dev/md126.
root@SSD128:/mnt# mount /dev/md127 /mnt/tmp
mount: /mnt/tmp: can’t read superblock on /dev/md127.
root@SSD128:/mnt#
root@SSD128:/mnt# mdadm –verbose –assemble –force /dev/md127 /dev/sdh4
mdadm: looking for devices for /dev/md127
mdadm: /dev/sdh4 is busy – skipping
root@SSD128:/mnt# mdadm –stop /dev/md127
mdadm: stopped /dev/md127
root@SSD128:/mnt# mdadm –verbose –assemble –force /dev/md127 /dev/sdh4
mdadm: looking for devices for /dev/md127
mdadm: /dev/sdh4 is identified as a member of /dev/md127, slot 0.
mdadm: no uptodate device for slot 1 of /dev/md127
mdadm: added /dev/sdh4 to /dev/md127 as 0
mdadm: /dev/md127 has been started with 1 drive (out of 2).

…. To Be Completed …

 

 

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *